Nintendo released a new firmware for the Nintendo DSi and DSi XL/LL today. The new firmware is 1.4.1 and this new firmware adds nothing but new anti-piracy.

We recommend NOT to update as most flashcarts do not work on this firmware. 1.4.1 has blocked the Supercard DStwo, Acekard 2i, Supercard DSonei, M3i Zero, DSTTi, and all other flashcarts.

Only 2 flashcarts currently work on 1.4.1 which is the new iSmartDS and the EZ-Flash Vi . If you have already updated and your Acekard 2i or other flashcart you will have to wait for a fix which might take from a day to next year or buy the iSmartDS or EZflash Vi from Gamekool that work on this firmware.

Post to Twitter

Related Posts:

  • No Related Posts